Les documents proposés sur ce site ont été testés et validés par différentes installations mais ne sauraient engager la responsabilité de la société en cas de problèmes ou de pertes de données si les modifications n'ont pas été réalisées par la société elle même.

Compléments d'installation pour Hardy Heron 8.04

Après l'installation, il est courant de rajouter toujours les mêmes paquets afin de retrouver les fonctionalités auxquelles on s'était habitué.

Pour ne pas en oublier, voici un article les recensant 1)

Vous pouvez aussi utiliser ce métapaquet installant l'ensemble des logiciels décrits ci dessous]]

Dépots

Pour installer les logiciels de cette page, vous devez avoir les dépôts universe, multiverse et medibuntu activés.

La page http://doc.ubuntu-fr.org/depots_hardy recence les dépôts disponibles et les indications pour activer d'autres dépôts.

Vous pouvez aussi, simplement, activer le dépôt medibuntu en installant le paquet ci dessous

Installer les dépôts medibuntu

puis activer les dépôts Universe et Multiverse en suivant l'information ci dessous

Les dépôts Universe et Multiverse ne sont pas des dépôts en eux-mêmes mais des sections des dépôts principaux. Elles contiennent des paquets maintenus uniquement par la communauté.

Pour les activer (conseillé) il suffit d'ouvrir l'interface de gestion des dépôts (Système→Administration→Sources de logiciels), dans l'onglet Logiciels Ubuntu, de cocher la case Logiciels Open Source maintenus par la communauté (universe), ainsi que la case Logiciels soumis au droit d'auteur ou à des restrictions légales (multiverse).

Multimedia

Pour être armé pour lire a peu prés tout ce qui ce fait en formats vidéo ou audio sur une Ubuntu 8.04 Hardy Heron fraîchement installée, voila une petite compilation de paquets à installer :

Nécessite l'activation des dépôts multiverse et medibuntu

Installer ces paquets

sudo apt-get install gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mp3 gstreamer0.10-fluendo-mpegdemux gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-plugins-bad faad ffmpeg gstreamer0.10-plugins-bad-multiverse lame lame-extras libfaad2-0 libmjpegtools0c2a mjpegtools sox libsox-fmt-all toolame mpeg2dec mpg321 vorbis-tools libdvdcss2 libdvdnav4 gxine mencoder mplayer mplayer-fonts mplayer-skins vlc w32codecs liba52-0.7.4-dev  mozilla-plugin-vlc ubuntu-restricted-extras mozilla-mplayer mplayer-fonts w32codecs flashplugin-nonfree libggi-target-x 
sudo apt-get install realplayer

Problèmes de son Firefox3b et flash

Installer nspluginwrapper a télécharger ici

Installer libflash support

 sudo apt-get install libflashsupport 

Supprimer le plugin flash

sudo apt-get remove --purge flashplugin-nonfree

Puis le réinstaller

sudo apt-get install flashplugin-nonfree

Relancer firefox, et le son devrait être présent sur les vidéos en flash

Compression

sudo apt-get install rar unrar lha

Manipulation d'images

sudo apt-get install nautilus-image-converter imagemagick

Polices

sudo apt-get install msttcorefonts gsfonts-x11 xfonts-75dpi-transcoded xfonts-100dpi-transcoded

java

sudo apt-get install sun-java6-plugin sun-java6-fonts

Langue

sudo apt-get install language-pack-fr language-pack-gnome-fr language-support-fr language-pack-kde-fr language-selector

Système

sudo apt-get install locate cron
1)
susceptible d'être incomplet et mis à jour au fur et à mesure

Outils personnels